// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\S*)[^\[]*\[(\S*)").unwrap();
let string = "241.78.197.101 - 6734 [05/Jan/2015:16:53:26:367 -0800] \"PUT /account/transfer HTTP/1.0\" 200 427
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}