import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\S*)[^\\[]*\\[(\\S*)";
final String string = "241.78.197.101 - 6734 [05/Jan/2015:16:53:26:367 -0800] \"PUT /account/transfer HTTP/1.0\" 200 427\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}