import Foundation
let pattern = #"(\S*)[^\[]*\[(\S*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
241.78.197.101 - 6734 [05/Jan/2015:16:53:26:367 -0800] "PUT /account/transfer HTTP/1.0" 200 427
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)