re = /(\S*)[^\[]*\[(\S*)/
str = '241.78.197.101 - 6734 [05/Jan/2015:16:53:26:367 -0800] "PUT /account/transfer HTTP/1.0" 200 427
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end