package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\S*)[^\[]*\[(\S*)`)
var str = `241.78.197.101 - 6734 [05/Jan/2015:16:53:26:367 -0800] "PUT /account/transfer HTTP/1.0" 200 427
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}