$re = '/(\S*)[^\[]*\[(\S*)/';
$str = '241.78.197.101 - 6734 [05/Jan/2015:16:53:26:367 -0800] "PUT /account/transfer HTTP/1.0" 200 427
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);