# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[13579](?=[13579])/$0-/gm;t' <<< "999463"