import Foundation
let pattern = #"[13579](?=[13579])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"999463"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$0-"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)