const regex = /[13579](?=[13579])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[13579](?=[13579])', 'gm')
const str = `999463`;
const subst = `$0-`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);