import re
regex = re.compile(r"[13579](?=[13579])", flags=re.MULTILINE)
test_str = "999463"
subst = "$0-"
result = regex.sub(subst, test_str)
if result:
print(result)