$re = '/[13579](?=[13579])/m';
$str = '999463';
$subst = "$0-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;