use strict;
my $str = '999463';
my $regex = qr/[13579](?=[13579])/mp;
my $subst = '$0-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";