const regex = /5002(?!H)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('5002(?!H)', 'g')
const str = `/?wkz=5002
/?wkz=5002HA-M
/?wkz=5002HB
/?wkz=5002HB-M
/?wkz=5002HF
/?wkz=5002HF-M`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}