import re
regex = re.compile(r"5002(?!H)")
test_str = ("/?wkz=5002\n"
"/?wkz=5002HA-M\n"
"/?wkz=5002HB \n"
"/?wkz=5002HB-M\n"
"/?wkz=5002HF \n"
"/?wkz=5002HF-M")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")