re = /5002(?!H)/
str = '/?wkz=5002
/?wkz=5002HA-M
/?wkz=5002HB
/?wkz=5002HB-M
/?wkz=5002HF
/?wkz=5002HF-M'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end