$re = '/5002(?!H)/';
$str = '/?wkz=5002
/?wkz=5002HA-M
/?wkz=5002HB
/?wkz=5002HB-M
/?wkz=5002HF
/?wkz=5002HF-M';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);