import Foundation
let pattern = #"5002(?!H)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/?wkz=5002
/?wkz=5002HA-M
/?wkz=5002HB
/?wkz=5002HB-M
/?wkz=5002HF
/?wkz=5002HF-M
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)