using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\W\d_]+(?:-[^\W\d_]+)*\.?$";
string input = @"Following types are fine:
John
Peter-Alexander
John.
Wiktor-Stribiżew
John-
Max!
Max123
Max 123
Max_
Max!""§$%&/()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}