import re
regex = re.compile(r"^[^\W\d_]+(?:-[^\W\d_]+)*\.?$", flags=re.MULTILINE)
test_str = ("Following types are fine:\n\n"
"John\n"
"Peter-Alexander\n"
"John.\n"
"Wiktor-Stribiżew\n"
"John-\n\n"
"Max!\n"
"Max123\n"
"Max 123\n"
"Max_\n"
"Max!\"§$%&/()")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")