// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\W\d_]+(?:-[^\W\d_]+)*\.?$").unwrap();
let string = "Following types are fine:
John
Peter-Alexander
John.
Wiktor-Stribiżew
John-
Max!
Max123
Max 123
Max_
Max!\"§$%&/()";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}