re = /^[^\W\d_]+(?:-[^\W\d_]+)*\.?$/m
str = 'Following types are fine:
John
Peter-Alexander
John.
Wiktor-Stribiżew
John-
Max!
Max123
Max 123
Max_
Max!"§$%&/()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end