package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\W\d_]+(?:-[^\W\d_]+)*\.?$`)
var str = `Following types are fine:
John
Peter-Alexander
John.
Wiktor-Stribiżew
John-
Max!
Max123
Max 123
Max_
Max!"§$%&/()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}