import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\W\\d_]+(?:-[^\\W\\d_]+)*\\.?$";
final String string = "Following types are fine:\n\n"
+ "John\n"
+ "Peter-Alexander\n"
+ "John.\n"
+ "Wiktor-Stribiżew\n"
+ "John-\n\n"
+ "Max!\n"
+ "Max123\n"
+ "Max 123\n"
+ "Max_\n"
+ "Max!\"§$%&/()";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}