$re = '/^[^\W\d_]+(?:-[^\W\d_]+)*\.?$/m';
$str = 'Following types are fine:
John
Peter-Alexander
John.
Wiktor-Stribiżew
John-
Max!
Max123
Max 123
Max_
Max!"§$%&/()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);