#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ims)<div\sclass=\"sg-text\">(.*?)<\/div>"
Local $sString = "<div class="brn-answer__content sg-content-box__content">" & @CRLF & _
"<div class="sg-content-box sg-content-box--spaced-bottom">" & @CRLF & _
"<div class="brn-answer__text">" & @CRLF & _
"<div class="sg-text">" & @CRLF & _
"Тут немного текста" & @CRLF & _
"</div>" & @CRLF & _
"</div>" & @CRLF & _
"<div class="brn-attachments brn-attachments--spaced-top">" & @CRLF & _
"<a href="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" class="brn-attachments__attachment" target="_blank">" & @CRLF & _
"<div class="sg-box sg-box--image-wrapper ">" & @CRLF & _
"<img class="sg-box__image" src="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" title="Photo" alt="">" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")