import Foundation
let pattern = #"<div\sclass=\"sg-text\">(.*?)<\/div>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"""
<div class="brn-answer__content sg-content-box__content">
<div class="sg-content-box sg-content-box--spaced-bottom">
<div class="brn-answer__text">
<div class="sg-text">
Тут немного текста
</div>
</div>
<div class="brn-attachments brn-attachments--spaced-top">
<a href="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" class="brn-attachments__attachment" target="_blank">
<div class="sg-box sg-box--image-wrapper ">
<img class="sg-box__image" src="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" title="Photo" alt="">
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)