const regex = /<div\sclass=\"sg-text\">(.*?)<\/div>/gims;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<div\\sclass=\\"sg-text\\">(.*?)<\\\/div>', 'gims')
const str = `<div class="brn-answer__content sg-content-box__content">
<div class="sg-content-box sg-content-box--spaced-bottom">
<div class="brn-answer__text">
<div class="sg-text">
Тут немного текста
</div>
</div>
<div class="brn-attachments brn-attachments--spaced-top">
<a href="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" class="brn-attachments__attachment" target="_blank">
<div class="sg-box sg-box--image-wrapper ">
<img class="sg-box__image" src="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" title="Photo" alt="">
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}