re = /<div\sclass=\"sg-text\">(.*?)<\/div>/im
str = '<div class="brn-answer__content sg-content-box__content">
<div class="sg-content-box sg-content-box--spaced-bottom">
<div class="brn-answer__text">
<div class="sg-text">
Тут немного текста
</div>
</div>
<div class="brn-attachments brn-attachments--spaced-top">
<a href="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" class="brn-attachments__attachment" target="_blank">
<div class="sg-box sg-box--image-wrapper ">
<img class="sg-box__image" src="https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg" title="Photo" alt="">
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end