import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div\\sclass=\\\"sg-text\\\">(.*?)<\\/div>";
final String string = "<div class=\"brn-answer__content sg-content-box__content\">\n"
+ "<div class=\"sg-content-box sg-content-box--spaced-bottom\">\n"
+ "<div class=\"brn-answer__text\">\n"
+ "<div class=\"sg-text\">\n"
+ "Тут немного текста\n"
+ "</div>\n"
+ "</div>\n"
+ "<div class=\"brn-attachments brn-attachments--spaced-top\">\n"
+ "<a href=\"https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg\" class=\"brn-attachments__attachment\" target=\"_blank\">\n"
+ "<div class=\"sg-box sg-box--image-wrapper \">\n"
+ "<img class=\"sg-box__image\" src=\"https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg\" title=\"Photo\" alt=\"\">\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}