# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div\sclass=\"sg-text\">(.*?)<\/div>"
test_str = ("<div class=\"brn-answer__content sg-content-box__content\">\n"
"<div class=\"sg-content-box sg-content-box--spaced-bottom\">\n"
"<div class=\"brn-answer__text\">\n"
"<div class=\"sg-text\">\n"
"Тут немного текста\n"
"</div>\n"
"</div>\n"
"<div class=\"brn-attachments brn-attachments--spaced-top\">\n"
"<a href=\"https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg\" class=\"brn-attachments__attachment\" target=\"_blank\">\n"
"<div class=\"sg-box sg-box--image-wrapper \">\n"
"<img class=\"sg-box__image\" src=\"https://site.ru/files/de1/b96e8076bba5b1c3bbd39a53d301c8a5.jpg\" title=\"Photo\" alt=\"\">\n"
"</div>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.