# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+/\1 \2 \3/gm;t' <<< "Шизофрений Шизофрениевич Шизофрениев"