const regex = /([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([А-Я])[а-я]+\\s+([А-Я])[а-я]+\\s+([А-Я])[а-я]+', 'gm')
const str = `Шизофрений Шизофрениевич Шизофрениев`;
const subst = `\1 \2 \3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);