use strict;
my $str = 'Шизофрений Шизофрениевич Шизофрениев';
my $regex = qr/([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+/mp;
my $subst = '\\1 \\2 \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";