// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+").unwrap();
let string = "Шизофрений Шизофрениевич Шизофрениев";
let substitution = "\\1 \\2 \\3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}