$re = '/([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+/m';
$str = 'Шизофрений Шизофрениевич Шизофрениев';
$subst = "\1 \2 \3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;