#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([А-Я])[а-я]+\s+([А-Я])[а-я]+\s+([А-Я])[а-я]+"
Local $sString = "Шизофрений Шизофрениевич Шизофрениев"
Local $sSubst = "\1 \2 \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)