# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|[^@\w])@(\w{1,30})\b(?!.*<\\/span>)/$1<span class="mention">@$2<\/span>/g;t' <<< "@name
email@website.com
a@b
@thisreallylongstringthatshouldntbematched
<span>@name</span>
<span class=\"mention\">@test</span> @test2
<span></span> @betweentwospans <span></span>
"