using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^@\w])@(\w{1,30})\b(?!.*<\/span>)";
string substitution = @"$1<span class=""mention"">@$2</span>";
string input = @"@name
email@website.com
a@b
@thisreallylongstringthatshouldntbematched
<span>@name</span>
<span class=""mention"">@test</span> @test2
<span></span> @betweentwospans <span></span>
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}