#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|[^@\w])@(\w{1,30})\b(?!.*<\/span>)"
Local $sString = "@name" & @CRLF & _
"email@website.com" & @CRLF & _
"a@b" & @CRLF & _
"@thisreallylongstringthatshouldntbematched" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<span>@name</span>" & @CRLF & _
"<span class="mention">@test</span> @test2" & @CRLF & _
"<span></span> @betweentwospans <span></span>" & @CRLF & _
""
Local $sSubst = "$1<span class="mention">@$2</span>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)