$re = '/(^|[^@\w])@(\w{1,30})\b(?!.*<\/span>)/';
$str = '@name
email@website.com
a@b
@thisreallylongstringthatshouldntbematched
<span>@name</span>
<span class="mention">@test</span> @test2
<span></span> @betweentwospans <span></span>
';
$subst = "$1<span class=\"mention\">@$2</span>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;