import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|[^@\\w])@(\\w{1,30})\\b(?!.*<\\/span>)";
final String string = "@name\n"
+ "email@website.com\n"
+ "a@b\n"
+ "@thisreallylongstringthatshouldntbematched\n\n\n"
+ "<span>@name</span>\n"
+ "<span class=\"mention\">@test</span> @test2\n"
+ "<span></span> @betweentwospans <span></span>\n";
final String subst = "$1<span class=\"mention\">@$2</span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}