# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n\n\n+/\n\n/g;t' <<< "\"Some text
some text\"
\"Some text
some text \n some other text\"
Some text
some text"