re = /\n\n\n+/
str = '"Some text
some text"
"Some text
some text \\n some other text"
Some text
some text'
subst = '\\n\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result