use strict;
my $str = '"Some text
some text"
"Some text
some text \\n some other text"
Some text
some text';
my $regex = qr/\n\n\n+/p;
my $subst = '\\n\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";