// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\n\n\n+").unwrap();
let string = "\"Some text
some text\"
\"Some text
some text \\n some other text\"
Some text
some text";
let substitution = "\\n\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}