import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n\\n\\n+";
final String string = "\"Some text \n"
+ " some text\"\n\n"
+ "\"Some text \n\n"
+ " some text \\n some other text\"\n\n"
+ "Some text \n\n\n"
+ " some text";
final String subst = "\\n\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}