package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\n\n\n+`)
var str = `"Some text
some text"
"Some text
some text \n some other text"
Some text
some text`
var substitution = "\n\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}