$re = '/\n\n\n+/';
$str = '"Some text
some text"
"Some text
some text \\n some other text"
Some text
some text';
$subst = "\n\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;