#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((^(\\\\).*)$)|((^[a-z]|[A-Z])[:][\\].*)$"
Local $sString = "\\mainnt\common\public common\bdelamater" & @CRLF & _
"C:\asdasdasd\asdasd" & @CRLF & _
"c:\asdklajsdlkajsd" & @CRLF & _
"0:\abc" & @CRLF & _
"ancC:\lkasjdlkajsd" & @CRLF & _
"asdasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")