import re
regex = re.compile(r"((^(\\\\).*)$)|((^[a-z]|[A-Z])[:][\\].*)$", flags=re.MULTILINE)
test_str = ("\\\\mainnt\\common\\public common\\bdelamater\n"
"C:\\asdasdasd\\asdasd\n"
"c:\\asdklajsdlkajsd\n"
"0:\\abc\n"
"ancC:\\lkasjdlkajsd\n"
"asdasd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")